This project is read-only.

Topological inconsistency after splitting a segment on simple data

Oct 11, 2017 at 9:16 PM
I was very happy to find, and am working through an issue.
I hope this project is still alive, last activity was a while ago.

Here is the data, it is three segments x,y,z vals:
Seg 1
from = 3470.24446228851,2026.74647195611,0.081678324900508
to = 3470.23824070941,2025.38518075843,0
Seg 2
from = 3470.23824070941,2025.38518075843,0
to = 3470.23554561524,2024.79548995642,-0.040289679343289
Seg 3
from = 3470.23824070941,2025.3851807584,0
to = 3469.65964599373,2025.84786418632,0

These are rounded to 15 sig figs
I noticed if I move the data closer to 0,0 the problem stops.
Hopefully this small set of data will be simple enough to reveal the problem.
Oct 12, 2017 at 12:13 AM
I figured it out, soooooooooo stoked.
As I was doing test cases, I noticed triangles were being split where I did not have points. I thought I had set minimum angle to 0, and I had, so why was this happening? I looked at the ConstraintOptions class and noticed the SegmentSplitting param. Sounds about exactly what I did not want on, so I set to 2. It worked. I tried on my "large dataset" way away from 0,0 and it worked perfect. I think my idea of no duplicate verts might be needed when segmentsplitting is on, but never tried it. Hopefully others benefit from my 8 hours playing around with this.

I duplicated this post on the Github site, so I know its in two places, and I think its worth having it in both.
I sure wish I had the contact name of someone familiar with this set of code, I could hire them here and there and point them to others that would want their help too.
I still feel like I have not decently explored what can do.